using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i)username=(.+)\nserver_name=(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})";
string input = @"username=igor_lakhtenkov
server_name=192.168.122.87
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}