$re = '/^(?=.*[A-Za-z])[\w_]+$/m';
$str = '1234abc
1234
1234a_
1234abc
abc_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);