re = /(?<!_)_([a-zA-Z0-9]+)\b/m
str = 'Calculate the _area of the _perfectRectangle object.
The _id and _age variables are both integers.
__invalidVariable _evenMoreInvalidVariable_ _validVariable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end