$re = '`\b(\d+\.)\h+(\d+KWh)`m';
$str = 'EB:3668. 19KWh DB:22. 29KWh
EB:3668.19KWh DB:22.29KWh';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;