package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/d\/(.*?)(\/|$)`)
var str = `https://docs.google.com/spreadsheets/d/1mrsetjgfZI2BIypz7SGHMOfHGv6kTKTzY0xOM5c6TXY/edit#gid=1842172258
https://docs.google.com/a/example.com/spreadsheets/d/1mrsetjgfZI2BIypz7SGHMOfHGv6PTKTzY0xOM5c6TXY/edit#gid=1842172258
https://docs.google.com/spreadsheets/d/1mrsetjgfZI2BIypz7SGHMOfHGv6kTKTzY0xOM5c6TXY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}