#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([ ]*(?:[-]|[+])?[ ]*\d+(?:,\d+|))([ ]*(?:[+]|[-])[ ]*(?:\d+(?:,\d+|)[ ]*[*]?[ ]*|)i[ ]*|[ ]*)$"
Local $sString = "1421" & @CRLF & _
"-124" & @CRLF & _
"-1245," & @CRLF & _
"1234," & @CRLF & _
"1235,002400" & @CRLF & _
"12435,000" & @CRLF & _
"-132435,0" & @CRLF & _
"+134235,014000" & @CRLF & _
"-1324,42 +i" & @CRLF & _
"345,4+ i*452,0250" & @CRLF & _
"+345-i452,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")