package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?x)^
(
(?:
[^{}\<\>] |
\{(?1)\} |
\<(?1)\>
)
*+
)
$`)
var str = `{}{<>{<>}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}