re = /^(?!(http)).*\.(png|jpg|jpeg)$/mi
str = 'http://123.png
1213.png
/123.jpg
666.png
https://2.png
./2.png
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end