re = /(^text$|text | text)/m
str = ' text .text. \'text\'
text .text. \'text\'
text
text
text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end