import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?iu)\\b((у|[нз]а|(хитро|не)?вз?[ыьъ]|с[ьъ]|(и|ра)[зс]ъ?|(о[тб]|под)[ьъ]?|(.\\B)+?[оаеи])?-?([её]б(?!о[рй])|и[пб][ае][тц]).*?|(н[иеа]|([дп]|верт)о|ра[зс]|з?а|с(ме)?|о(т|дно)?|апч)?-?ху([яйиеёю]|ли(?!ган)).*?|(в[зы]|(три|два|четыре)жды|(н|сук)а)?-?бл(я(?!(х|ш[кн]|мб)[ауеыио]).*?|[еэ][дт]ь?)|(ра[сз]|[зн]а|[со]|вы?|п(ере|р[оие]|од)|и[зс]ъ?|[ао]т)?п[иеё]зд.*?|(за)?п[ие]д[аое]?р(ну.*?|[оа]м|(ас)?(и(ли)?[нщктл]ь?)?|(о(ч[еи])?|ас)?к(ой)|юг)[ауеы]?|манд([ауеыи](л(и[сзщ])?[ауеиы])?|ой|[ао]вошь?(е?к[ауе])?|юк(ов|[ауи])?)|((за|вы|под|на|об|по)?трах(ну(сь|ть)?|ни(сь)?|ать|ай))|(сучк([уеаи]))|(з[ал]луп([уеаи]?))|(жоп([уеыаи]))|муд([яаио].*?|е?н([ьюия]|ей))|мля([тд]ь)?|лять|([нз]а|по)х|м[ао]л[ао]фь([яию]|[еёо]й))\\b";
final String string = "Щас будете ебать меня.\n"
+ "Мы тебя так выебем, ты ахуеешь. Посмотрю-посмотрю, на что ты способен, сукаблять.\n"
+ "Я блядь, я хочу ебаться. Я блядская сучка, я хочу чтоб ты выебал меня. - Щас тебя выебу.- Давай! Выеби меня, выеби!!!\n"
+ "Засунь свой хуй мне в рот, посмотри на мои блядские губы.\n"
+ "Я твоя блядь ебаная, я хочу, чтоб ты ебал меня!\n"
+ "Мои блядские губы хотят сосать твой хуй.\n"
+ "Посмотри на мои блядские соски! Я хочу, чтоб ты сосал их! Выеби меня во все дыры, я твоя блядь, я твоя сука ебанннная!\n"
+ "Я хочу ебаться в рот, еби меня в рот, суку.\n"
+ "Щас я вставлю твой хуй себе в жопу и ты выебешь меня.- Давай-давай, вот так вот, сучка.\n"
+ "Отъебите меня, сучку!\n"
+ "Я хочу тебя ебать, ебать, ебать!\n"
+ "Двигайся, двигайся, ебливая сука!\n"
+ "Давай, там поглубже, а я впизду!!!\n"
+ "Давайте суки, трахайте меняяяяя!!!\n"
+ "Я такая блядь, я хочу ебаться! - Ну и ебись!\n"
+ "Пошла залупа!\n"
+ "Сука... Трахай меня в попу!\n"
+ "Иди сюда, я буду сосать твой хуй!\n"
+ "Хорошо тебе ебаться, да?!\n"
+ "Трахай меня, че остановился, ебанько?!\n"
+ "ООО БЛЯЯЯЯЯЯЯЯЯЯ!!!\n"
+ "Пизденка тепленькая... Как в жопе, брат?\n"
+ "Какие у тебя энергичные сиськи!\n"
+ "Я хочу сосать ваши хуи! - Соси, соси, сучка!\n\n"
+ "Пососи\n"
+ "У, у, у, у, у (ва-а, ху-у)\n"
+ "Да, я богатый уёбок (е)\n"
+ "У меня денег так много (cash)\n"
+ "Моё ебало — коробка\n"
+ "(У, у, у, у, у; ва-а, ху-у)\n"
+ "Хули, бля, ты такой робкий? (Е)\n"
+ "Ты же базарил так громко (пиздел)\n"
+ "Да так и быть делай фотку (ху-у)\n"
+ "(Пока я добрый, сучка; ха-ха)\n"
+ "Да, я пиздец охуевший (да)\n"
+ "Сука твоя без одежды, эй (у, у, у, у)\n"
+ "Я подарю ей нежность (секс)\n"
+ "(Иди сюда; ы-ы)\n"
+ "Прыг-прыг ей прямо меж ног (да; ху-у)\n"
+ "Доедаю промежность (ам)\n"
+ "Это, сука, любовь (мва)\n"
+ "Хули ты мне ща вякнешь? (А-а?)\n"
+ "Сука, ты сын домашний (соси)\n"
+ "Rollie на мне — швейцарский (блеск)\n"
+ "Цепь на мне — это важно (chain)\n"
+ "Иди покушай ты кашу (ам)\n"
+ "Я пока ногти накрашу (ва-а)\n"
+ "Суки твоей буду краше (я-а)\n"
+ "Она зовёт меня крашем, эй\n"
+ "Я легенда, как Цой (эй; Цой)\n"
+ "Но такой молодой (Цой)\n"
+ "Подавился мацой, эй (а-а-ву-у)\n"
+ "Думай, типа тупой, эй\n"
+ "Думай это, мне похуй (похуй; эй)\n"
+ "Чё, DaBaby? Да похуй (да похуй; эй)\n"
+ "Хуй огромный, как пенис (член)\n"
+ "На мне прыгает жопа\n"
+ "Bounce, bounce, bounce, bounce\n"
+ "Bounce, bounce, bounce, bounce\n"
+ "Bounce, bounce, bounce, bounce\n"
+ "Bounce, я всё\n"
+ "Шутки в сторону, сука, эй\n"
+ "Я тебе чё, Иуда? (What?)\n"
+ "С государством работал? (Нет)\n"
+ "Не, но теперь буду (да)\n"
+ "Чё ещё? Типа байтер? (What?)\n"
+ "Сделал деньги на даунах? (Да)\n"
+ "Да, это так, но\n"
+ "На даунах, что хейтят меня в комментариях!\n"
+ "У, у, у, у, у (ва-а, ху-у)\n"
+ "Да, я богатый уёбок (е)\n"
+ "У меня денег так много (cash; ага)\n"
+ "Моё ебало — коробка\n"
+ "(У, у, у, у, у; ху-у; вода)\n"
+ "Хули, бля, ты такой робкий?\n"
+ "Ты же базарил так громко (пиздел)\n"
+ "Да так и быть делай фотку (ху-у)\n"
+ "(Трясутся ручки, ха-ха)\n"
+ "Да, я пиздец охуевший (да)\n"
+ "Сука твоя без одежды, эй\n"
+ "Я подарю ей нежность (секс)\n"
+ "(У, у, у, у, у; иди сюда)\n"
+ "Прыг-прыг ей прямо меж ног (да)\n"
+ "Доедаю промежность (ам-ам)\n"
+ "Это, сука, любовь\n"
+ "Слава, что ты сд—\n\n"
+ "У меня болезнь зоофилия\n"
+ "Меня очень тянет на собак\n"
+ "Бросила меня девчонка Лия\n"
+ "И сказала то что я — Мудак\n"
+ "Я ебу собак!\n"
+ "Всегда готов сразу трахнуть несколько котов\n"
+ "Да, я зоофил, не говори, лучше мне собачку подари!\n"
+ "Мне собачку утром трахнуть — мало\n"
+ "Надо утром, вечером и днём\n"
+ "У меня вчера змея сосала\n"
+ "А сегодня я ебусь с ежом\n"
+ "Я ебу собак!\n"
+ "Всегда готов сразу трахнуть несколько котов\n"
+ "Да, я зоофил, не говори, лучше мне собачку подари!\n"
+ "Мама принесла вчера котёнка\n"
+ "На ночь я его к себе забрал\n"
+ "Положил котёнка на пелёнку\n"
+ "Сразу во все дыры отъебал\n"
+ "Я ебу собак!\n"
+ "Всегда готов сразу трахнуть несколько котов\n"
+ "Да, я зоофил, не говори, лучше мне собачку подари!\n\n"
+ "трахни трахну трахать трахнись трахнусь трахнуть затрахать вытрахать подтрахать обтрахать обтрахай затрахай";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}