use strict;
my $str = 'Щас будете ебать меня.
Мы тебя так выебем, ты ахуеешь. Посмотрю-посмотрю, на что ты способен, сукаблять.
Я блядь, я хочу ебаться. Я блядская сучка, я хочу чтоб ты выебал меня. - Щас тебя выебу.- Давай! Выеби меня, выеби!!!
Засунь свой хуй мне в рот, посмотри на мои блядские губы.
Я твоя блядь ебаная, я хочу, чтоб ты ебал меня!
Мои блядские губы хотят сосать твой хуй.
Посмотри на мои блядские соски! Я хочу, чтоб ты сосал их! Выеби меня во все дыры, я твоя блядь, я твоя сука ебанннная!
Я хочу ебаться в рот, еби меня в рот, суку.
Щас я вставлю твой хуй себе в жопу и ты выебешь меня.- Давай-давай, вот так вот, сучка.
Отъебите меня, сучку!
Я хочу тебя ебать, ебать, ебать!
Двигайся, двигайся, ебливая сука!
Давай, там поглубже, а я впизду!!!
Давайте суки, трахайте меняяяяя!!!
Я такая блядь, я хочу ебаться! - Ну и ебись!
Пошла залупа!
Сука... Трахай меня в попу!
Иди сюда, я буду сосать твой хуй!
Хорошо тебе ебаться, да?!
Трахай меня, че остановился, ебанько?!
ООО БЛЯЯЯЯЯЯЯЯЯЯ!!!
Пизденка тепленькая... Как в жопе, брат?
Какие у тебя энергичные сиськи!
Я хочу сосать ваши хуи! - Соси, соси, сучка!
Пососи
У, у, у, у, у (ва-а, ху-у)
Да, я богатый уёбок (е)
У меня денег так много (cash)
Моё ебало — коробка
(У, у, у, у, у; ва-а, ху-у)
Хули, бля, ты такой робкий? (Е)
Ты же базарил так громко (пиздел)
Да так и быть делай фотку (ху-у)
(Пока я добрый, сучка; ха-ха)
Да, я пиздец охуевший (да)
Сука твоя без одежды, эй (у, у, у, у)
Я подарю ей нежность (секс)
(Иди сюда; ы-ы)
Прыг-прыг ей прямо меж ног (да; ху-у)
Доедаю промежность (ам)
Это, сука, любовь (мва)
Хули ты мне ща вякнешь? (А-а?)
Сука, ты сын домашний (соси)
Rollie на мне — швейцарский (блеск)
Цепь на мне — это важно (chain)
Иди покушай ты кашу (ам)
Я пока ногти накрашу (ва-а)
Суки твоей буду краше (я-а)
Она зовёт меня крашем, эй
Я легенда, как Цой (эй; Цой)
Но такой молодой (Цой)
Подавился мацой, эй (а-а-ву-у)
Думай, типа тупой, эй
Думай это, мне похуй (похуй; эй)
Чё, DaBaby? Да похуй (да похуй; эй)
Хуй огромный, как пенис (член)
На мне прыгает жопа
Bounce, bounce, bounce, bounce
Bounce, bounce, bounce, bounce
Bounce, bounce, bounce, bounce
Bounce, я всё
Шутки в сторону, сука, эй
Я тебе чё, Иуда? (What?)
С государством работал? (Нет)
Не, но теперь буду (да)
Чё ещё? Типа байтер? (What?)
Сделал деньги на даунах? (Да)
Да, это так, но
На даунах, что хейтят меня в комментариях!
У, у, у, у, у (ва-а, ху-у)
Да, я богатый уёбок (е)
У меня денег так много (cash; ага)
Моё ебало — коробка
(У, у, у, у, у; ху-у; вода)
Хули, бля, ты такой робкий?
Ты же базарил так громко (пиздел)
Да так и быть делай фотку (ху-у)
(Трясутся ручки, ха-ха)
Да, я пиздец охуевший (да)
Сука твоя без одежды, эй
Я подарю ей нежность (секс)
(У, у, у, у, у; иди сюда)
Прыг-прыг ей прямо меж ног (да)
Доедаю промежность (ам-ам)
Это, сука, любовь
Слава, что ты сд—
У меня болезнь зоофилия
Меня очень тянет на собак
Бросила меня девчонка Лия
И сказала то что я — Мудак
Я ебу собак!
Всегда готов сразу трахнуть несколько котов
Да, я зоофил, не говори, лучше мне собачку подари!
Мне собачку утром трахнуть — мало
Надо утром, вечером и днём
У меня вчера змея сосала
А сегодня я ебусь с ежом
Я ебу собак!
Всегда готов сразу трахнуть несколько котов
Да, я зоофил, не говори, лучше мне собачку подари!
Мама принесла вчера котёнка
На ночь я его к себе забрал
Положил котёнка на пелёнку
Сразу во все дыры отъебал
Я ебу собак!
Всегда готов сразу трахнуть несколько котов
Да, я зоофил, не говори, лучше мне собачку подари!
трахни трахну трахать трахнись трахнусь трахнуть затрахать вытрахать подтрахать обтрахать обтрахай затрахай трахаю потрахаю затрахана трахали трахала
трахай трахал
сучкой жопой залупой залупы залуп';
my $regex = qr/(?iu)\b((у|[нз]а|(хитро|не)?вз?[ыьъ]|с[ьъ]|(и|ра)[зс]ъ?|(о[тб]|под)[ьъ]?|(.\B)+?[оаеи])?-?([её]б(?!о[рй])|и[пб][ае][тц]).*?|(н[иеа]|([дп]|верт)о|ра[зс]|з?а|с(ме)?|о(т|дно)?|апч)?-?ху([яйиеёю]|ли(?!ган)).*?|(в[зы]|(три|два|четыре)жды|(н|сук)а)?-?бл(я(?!(х|ш[кн]|мб)[ауеыио]).*?|[еэ][дт]ь?)|(ра[сз]|[зн]а|[со]|вы?|п(ере|р[оие]|од)|и[зс]ъ?|[ао]т)?п[иеё]зд.*?|(за)?п[ие]д[аое]?р(ну.*?|[оа]м|(ас)?(и(ли)?[нщктл]ь?)?|(о(ч[еи])?|ас)?к(ой)|юг)[ауеы]?|манд([ауеыи](л(и[сзщ])?[ауеиы])?|ой|[ао]вошь?(е?к[ауе])?|юк(ов|[ауи])?)|((за|вы|под|на|об|по)?трах(ну(сь|ть)?|ни(сь)?|ать|а([юяй]|л([аи])?|н([аыо])?)))|(сучк([уеаи]|ой))|(залуп(([уеаиы]|ой)?))|(жоп([уеыаи]|ой))|муд([яаио].*?|е?н([ьюия]|ей))|мля([тд]ь)?|лять|([нз]а|по)х|м[ао]л[ао]фь([яию]|[еёо]й))\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}