#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?P<LE10>(?:0[0-9]|1[0-9]|2[0-8]|3[0-7]|4[0-6]|5[0-5]|6[0-4]|7[0-3]|8[0-2]|9[0-1])))?(?:(?:X|(?P>LE10))-){9}(?:XXX|XX\d|X?(?P>LE10)|(?:19|28|37|46|55|64|7|3|82|91)[X\d])$"
Local $sString = "X-91-55-72-X-X-X-90-71-91X" & @CRLF & _
"X-91-55-72-X-X-X-90-82-XXX" & @CRLF & _
"X-91-55-72-X-X-X-90-82-XX7" & @CRLF & _
"X-91-55-72-X-X-X-90-82-X91" & @CRLF & _
"X-91-55-72-X-X-X-90-82-90" & @CRLF & _
"X-91-55-72-X-X-X-90-82-X91" & @CRLF & _
"X-91-55-72-X-X-X-90-82-917" & @CRLF & _
"X-91-72-X-X-X-90-82-917" & @CRLF & _
" Number of delimiters (8) incorrect" & @CRLF & _
"X-91-55-7-X-X-X-90-82-91X" & @CRLF & _
" 7 in first 9 is invalid" & @CRLF & _
"X-91-55-72-X-X-X-X94-82-91X" & @CRLF & _
" X94 in first 9 is invalid" & @CRLF & _
"X-91-55-72-X-X-X-90-82-X" & @CRLF & _
" last = X is not valid" & @CRLF & _
"X-91-55-72-X-X-X-90-82-XX" & @CRLF & _
" last = XX is not valid" & @CRLF & _
"X-91-55-72-X-X-X-90-82-XXXX" & @CRLF & _
" last = XXXX is not valid " & @CRLF & _
"X-91-55-72-X-X-X-90-82-X92" & @CRLF & _
" last = X92 is not valid" & @CRLF & _
"X-91-55-72-X-X-X-90-82-94" & @CRLF & _
" last = 94 is not valid" & @CRLF & _
"X-91-55-72-X-X-X-90-82-62X" & @CRLF & _
" last = 62X is not valid" & @CRLF & _
"X-91-55-72-X-X-X-90-82-927" & @CRLF & _
" last = 927 is not valid" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")