$re = '/\([^(}]*\K\}/m';
$str = 'Accord}ing to Martin (1970: 59}, the job of someone who explains something to someone "is to fill in the gap between his audience\'s knowledge or beliefs about some phenomena and what he takes to be the actual state of affairs".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);