$re = '/[a-z][A-Z]+/m';
$str = 'Hola123
hola
Hola
HOLA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);