import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">[^<>]+<";
final String string = "<html>\n\n"
+ "<head>\n"
+ "<meta http-equiv=\"Content-Type\" content=\"text/html; charset=windows-1252\">\n"
+ "<title>Suessgraeser</title>\n"
+ "<meta name=\"GENERATOR\" content=\"Microsoft FrontPage 4.0\">\n"
+ "<meta name=\"ProgId\" content=\"FrontPage.Editor.Document\">\n"
+ "<meta name=\"Microsoft Theme\" content=\"expeditn 011, default\">\n"
+ "<meta name=\"Microsoft Border\" content=\"none, default\">\n"
+ "</head>\n\n"
+ "<body background=\"../../_themes/expeditn/exptextb.jpg\" bgcolor=\"#FFFFFF\" text=\"#000000\" link=\"#993300\" vlink=\"#666600\" alink=\"#CC3300\"><!--mstheme--><font face=\"Book Antiqua, Times New Roman, Times\">\n"
+ "<p align=\"center\"><!--webbot bot=\"Navigation\" S-Type=\"top\"\n"
+ "S-Orientation=\"horizontal\" S-Rendering=\"graphics\" B-Include-Home=\"TRUE\"\n"
+ "B-Include-Up=\"TRUE\" U-Page S-Target startspan --><script language=\"JavaScript\"><!--\n"
+ "MSFPhover = \n"
+ " (((navigator.appName == \"Netscape\") && \n"
+ " (parseInt(navigator.appVersion) >= 3 )) || \n"
+ " ((navigator.appName == \"Microsoft Internet Explorer\") && \n"
+ " (parseInt(navigator.appVersion) >= 4 ))); \n"
+ "function MSFPpreload(img) \n"
+ "{\n"
+ " var a=new Image(); a.src=img; return a; \n"
+ "}\n"
+ "// --></script><script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav1n=MSFPpreload(\"../../_derived/home_cmp_expeditn010_hbtn.gif\"); MSFPnav1h=MSFPpreload(\"../../_derived/home_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../index.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav1'].src=MSFPnav1h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav1'].src=MSFPnav1n.src\"><img src=\"../../_derived/home_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Home\" align=\"middle\" name=\"MSFPnav1\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav2n=MSFPpreload(\"../../_derived/up_cmp_expeditn010_hbtn.gif\"); MSFPnav2h=MSFPpreload(\"../../_derived/up_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../monoco_gras.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav2'].src=MSFPnav2h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav2'].src=MSFPnav2n.src\"><img src=\"../../_derived/up_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Nach oben\" align=\"middle\" name=\"MSFPnav2\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav3n=MSFPpreload(\"../../Hauptgruppen/_derived/Systematik.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav3h=MSFPpreload(\"../../Hauptgruppen/_derived/Systematik.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../Hauptgruppen/Systematik.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav3'].src=MSFPnav3h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav3'].src=MSFPnav3n.src\"><img src=\"../../Hauptgruppen/_derived/Systematik.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Systematik\" align=\"middle\" name=\"MSFPnav3\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav4n=MSFPpreload(\"../../Bestimmung/_derived/bestimmung.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav4h=MSFPpreload(\"../../Bestimmung/_derived/bestimmung.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../Bestimmung/bestimmung.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav4'].src=MSFPnav4h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav4'].src=MSFPnav4n.src\"><img src=\"../../Bestimmung/_derived/bestimmung.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Bestimmung\" align=\"middle\" name=\"MSFPnav4\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav5n=MSFPpreload(\"../../_derived/bestimmungsschluessel.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav5h=MSFPpreload(\"../../_derived/bestimmungsschluessel.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../bestimmungsschluessel.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav5'].src=MSFPnav5h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav5'].src=MSFPnav5n.src\"><img src=\"../../_derived/bestimmungsschluessel.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Familien\" align=\"middle\" name=\"MSFPnav5\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav6n=MSFPpreload(\"../../Fundorte/_derived/fundorte.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav6h=MSFPpreload(\"../../Fundorte/_derived/fundorte.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../Fundorte/fundorte.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav6'].src=MSFPnav6h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav6'].src=MSFPnav6n.src\"><img src=\"../../Fundorte/_derived/fundorte.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Fundorte\" align=\"middle\" name=\"MSFPnav6\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav7n=MSFPpreload(\"../../Fachbegriffe/_derived/fachbegriffe.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav7h=MSFPpreload(\"../../Fachbegriffe/_derived/fachbegriffe.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../Fachbegriffe/fachbegriffe.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav7'].src=MSFPnav7h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav7'].src=MSFPnav7n.src\"><img src=\"../../Fachbegriffe/_derived/fachbegriffe.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Fachbegriffe\" align=\"middle\" name=\"MSFPnav7\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav8n=MSFPpreload(\"../../_derived/artenverzeichnis1.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav8h=MSFPpreload(\"../../_derived/artenverzeichnis1.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../artenverzeichnis1.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav8'].src=MSFPnav8h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav8'].src=MSFPnav8n.src\"><img src=\"../../_derived/artenverzeichnis1.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Artenverzeichnis\" align=\"middle\" name=\"MSFPnav8\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav9n=MSFPpreload(\"../../Hilfe/_derived/hilfe.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav9h=MSFPpreload(\"../../Hilfe/_derived/hilfe.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../Hilfe/hilfe.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav9'].src=MSFPnav9h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav9'].src=MSFPnav9n.src\"><img src=\"../../Hilfe/_derived/hilfe.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Hilfe\" align=\"middle\" name=\"MSFPnav9\"></a> <script language=\"JavaScript\"><!--\n"
+ "if(MSFPhover) { MSFPnav10n=MSFPpreload(\"../../_derived/saatblumen.htm_cmp_expeditn010_hbtn.gif\"); MSFPnav10h=MSFPpreload(\"../../_derived/saatblumen.htm_cmp_expeditn010_hbtn_a.gif\"); }\n"
+ "// --></script><a href=\"../../saatblumen.htm\" language=\"JavaScript\" onmouseover=\"if(MSFPhover) document['MSFPnav10'].src=MSFPnav10h.src\" onmouseout=\"if(MSFPhover) document['MSFPnav10'].src=MSFPnav10n.src\"><img src=\"../../_derived/saatblumen.htm_cmp_expeditn010_hbtn.gif\" width=\"140\" height=\"50\" border=\"0\" alt=\"Saatblumen\" align=\"middle\" name=\"MSFPnav10\"></a><!--webbot bot=\"Navigation\" endspan i-checksum=\"53857\" -->\n"
+ "</p>\n"
+ "<p align=\"center\"><b><font color=\"#FF0000\" size=\"6\">Familie: Süßgräser (Poaceae,\n"
+ "Graminaceae)</font></b></p>\n"
+ "<p align=\"center\"><b><font size=\"4\" color=\"#0000FF\">Zur Familie gehören 668\n"
+ "Gattungen mit ca. 1000 Arten.</font></b></p>\n"
+ "<p align=\"center\"><b><font color=\"#0000FF\" size=\"4\">Süßgräser sind gekennzeichnet durch einen runden, hohlen\n"
+ "rundlichen Halm. <br>\n"
+ "Viele <a href=\"getreide.htm\">Getreidearten</a> gehören zu den Süßgräsern.</font></b></p>\n"
+ "<p align=\"center\">\n"
+ "<font size=\"4\" color=\"#0000FF\"><b>> <a href=\"aufbau_suessgras.htm\">Zum\n"
+ "Aufbau eines Süßgrases</a></b></font></p>\n"
+ "<!--mstheme--></font><table border=\"1\" width=\"100%\" bordercolordark=\"#660000\" bordercolorlight=\"#CC9966\">\n"
+ " <tr>\n"
+ " <td width=\"50%\" align=\"center\" valign=\"top\"><!--mstheme--><font face=\"Book Antiqua, Times New Roman, Times\"><b><font size=\"3\"> Pflanze 1, 5 m -\n"
+ " 6 m groß<br>\n"
+ "Halm mindestens 1 cm dick<br>\n"
+ "> <a href=\"gras_gross.htm\">Große Gräser</a></font></b>\n"
+ " <p><b><img border=\"0\" src=\"P1530625.JPG_a.jpg\" width=\"272\" height=\"581\"></b><!--mstheme--></font></td>\n"
+ " <td width=\"50%\" align=\"center\" valign=\"top\"><!--mstheme--><font face=\"Book Antiqua, Times New Roman, Times\"><b><font size=\"3\">\n"
+ "Pflanzen kleiner<br>\n"
+ "Halm dünner als 1 cm<br>\n"
+ "> <a href=\"gras_klein.htm\">Kleine Gräser</a></font></b><!--mstheme--></font></td>\n"
+ " </tr>\n"
+ "</table><!--mstheme--><font face=\"Book Antiqua, Times New Roman, Times\">\n"
+ "<p align=\"left\"><b><font size=\"3\"> </font></b></p>\n"
+ "<p align=\"left\"> </p>\n"
+ "<!--mstheme--></font></body>\n\n"
+ "</html>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}