import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span[^>]*>.*?<\\/span>";
final String string = "<p>Qualifiers are used to adjust qualities of an object or a variable.</p>\n"
+ "<p>There are two types of qualifiers in C++. CV <span style=\"color: #3665f3;\"><strong>Qualifiers</strong></span> and Storage Duration <span style=\"color: #3665f3;\"><strong>Qualifiers</strong></span>. CV stands for constant and volatile.</p>\n"
+ "<p>CV <span style=\"color: #3665f3;\"><strong>Qualifiers</strong></span></p>\n"
+ "<ul>\n"
+ "<li>const - marks a variable as read-only or immutable.</li>\n"
+ "<li>mutable - is used on data members to make them writable from a const qualified member function.</li>\n"
+ "<li>volatile - mark a variable that may be changed by another process. This is partly deprecated in C++ 20.</li>\n"
+ "</ul>\n"
+ "<p>Storage Duration Qualifiers are used to define the duration or lifetime of a variable. By default, a variable defined within a block has an automatic lifetime.</p>\n"
+ "<p>Storage Duration <span style=\"color: #3665f3;\"><strong>Qualifiers</strong></span></p>\n"
+ "<ul>\n"
+ "<li>static - variables defined to have life <span>beyond</span> the execution of a block. Static variables live for the duration of the program. Commonly used for keeping state between usages between a given function or a method. By default a variable defined outside of any block is static.</li>\n"
+ "<li>register - are variables stored in processor registers. This can make them faster <span style=\"color: #3665f3;\"><strong>Qualifiers</strong></span> and more efficient. This qualifier is taken by the compiler as a suggestion. The compiler may or may not store the variable in a register.</li>\n"
+ "<li>extern variables are defined in a separate translation unit. These are linked with your code with the linker step of the compilation process.</li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}