#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([A-Za-z_]+)|\"[^".]+\"|([>,])"
Local $sString = "jsx_expression > "{", jsx_expression > ","" & @CRLF & _
"template_substitution > "${"" & @CRLF & _
"template_substitution > foo , bar" & @CRLF & _
"foo > bar > baz" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")