$re = '/\d/m';
$str = 'abcdefghijklmnopqrstuvwxyz
01234567890
~`!@#$%^&*()_+-=
{}|[]\\;\':",./<>?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);