$re = '/\S+( ?)-(\1| )\S+/m';
$str = 'test - dash
test- dash
test-dash
test -dash';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);