using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"robert (.+?) (?:palmer )+sent for the boat";
string input = @"robert eric palmer sent for the boat
robert eric william palmer sent for the boat
robert eric palmer palmer palmer sent for the boat
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}