$re = '/(?<=q=).*(?=\&key)/m';
$str = 'search?q=-26.106150272877,-56.89951582606415&key=AIzaSyBULWdjzDkVfa-hG9q-_TIv3MuhDdAA1Zc&zoom=14\\" width=\\"100%\\" height=\\"95%\\" frameborder=\\"0\\" style=\\"border:0; margin-top:10px;\\" allowfullscreen></iframe>\'); modalElm.modal(\'show\');modalElm.on(\'shown.bs.modal\', function() {});modalElm.on(\'hide.bs.modal\', function() {$(\'#map-canvas\').html(\'\');});}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);