package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2}:\d{2})<([@+]?[^>]*)>(.*)`)
var str = `= 00:00<@billy> text text text text text text text text text text text text text text text
= 00:03<+tom> text text text text text text
= 00:03<somedude> text text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}