$re = '/[^\/]+(?=\.[^\/.]*$)/m';
$str = '48494,Test,0000,Color,,,htps://url/test/testing/bb/1/dim/green.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);