import re
regex = re.compile(r"^(?:https?:\/\/)?(?:[^@\/\n]+@)?(?:www\.)?([^:\/?\n]+)?(\/)?([a-z]{2}-[a-z]{2})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("https://me.sumup.com/de-de/hello\n"
"https://me.sumup.com/hello\n"
"www.me.sumup.com/de-de/hello\n"
"me.sumup.com/br-br/hello")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")