const regex = /(\d{4})(-?\d{4}){3}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4})(-?\\d{4}){3}', 'g')
const str = `5123-4567-8912-3456
61234-567-8912-3456
4123356789123456
5133-3367-8912-3456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}