re = /[^\/]+$/
str = '/webshop/product/Brabantia-6L-Sort--Go-Waste-Bin-Grey/342586011'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end