$re = '/(?:[^<](?=[^<]*(\1?+<BckSp>)))+\1/';
$str = 'Helllo<BckSp><BckSp>o world';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);