re = /^(?!.{11})[a-z]+(?: [a-z]+)?$/m
str = 'asdf
asdf asdf
sdfasdf asdf
123456789012'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end