using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<pre>).*(?=<\/pre>)";
string input = @"<!-- NOTE: YOU MUST BE LOGGED IN TO EDIT THIS PAGE. SEE ABOVE FOR A LINK TO LOG IN. -->
{{Process header
| title = Wikimedia nomail list
| section =
| previous =
| next =
| shortcut =
| notes = Users listed below have requested that they get no announcements by email for board elections and referenda.
}}
Please enter ''just'' your username. The exclusion will apply to all accounts with that name on all wikis.
echo7tango
leksey
Nemo Le Poisson
Hvn0413
STUDENT57
Seboloidus
Viticulum
Jidanni
Jacquesverlaeken
Snowmanonahoe
Tallaussiebloke
Marc1403
Phil Champ
אריאל מואטי
Harry Audus
Petsgirl11211
Jo Jc Jo
Caleb Stanford
Travelrisk
raid5
LICA98
Smcm07
Eco-climber
btphelps
Black roses124
Giacomo1968
RenéV
Marsupilami
Treluxe
Wirjadisastra
The Gamer 91
Merlinhst7
Ratizi
Loginnigol
Viticulum
General Basset
Dream out loud
Pedia9jb6I
AlphaRex1984
GeneralKenobi918
AlH42
Caleb Stanford
David O. Johnson
Evangp
Eliskuya2
Arp242
Midperson
555
21655
Maimaid
10nm
16Exul82
1980fast
2ttr
A. Exeunt
A552745
Aaha
Äbäläfuchs
Abc82
Absconditus
Acartonado
achillemarotta
AchimP
Ackey7076
AdamKot34
ADM
ADNAN MIR
ADNghiem501
Aérospatial
Aexus
AFirefoxUser
Agaath
aghnon
Aiglemkf
Akcfif
Al Maghi
Alanmaher
Alch Bot
Aleth Bot
Alex Khimich
AlexandrDmitri
alexhangartner
Alexiaya
Alf aus Mannheim
Alghenius
Aliyu shaba
Alph Bot
Amator linguarum
Ammar Bail
Amy 98se
Anandhanju
Anareth
Anderjef
Andreateletrabajo
Andrevruas
AndreyNosatii
Androidpar
AndrzejSalwicki
AndSalx95
AnmaFinotera
anticalcare
Anton Sachs
Anybot
Apheniti
Apollovvv
Apple tarte
Aquatic Ambiance
Aregakn
Aristitleism
Arjen77
Armanic
Artem S. Tashkinov
Arturkozlov
Ashleyyy1
Astaroth15
Astrobeamer
Athaenara
Atón
Atorox (bot)
Attilaurm
AuburnPiIot
AuburnPilot
Autair
AvicAWB
AvicBot
AvicPublic
Aycan
Aziz Kingrani
Bachsau
Bakasuma
Balanagaraj
Banio ba Hinako
Baris6161TURK
Baron Langford
Barras
Barras (de)
Bastian
Bastianow
Batreeq
Bave-
Bbx
Bdanh
bdoserror
Bearnard O'Riain.
Beau.bot
Beau.bot.admin
Bellatrix Kerrigan
Belrien12
Benjiemartin2000
Benriggers
Berginspektor
Bernat (5)
BFP1
Bhanumet
Billy69150
BirchBarlow
Bishonen
Bishzilla
Black roses124
black_daw
Blsupr
BlueDevil
Bluehill
BluehillBot
BluehillBot A
BluehillBot B
Bodo Kubrak
Boing! said Zebedee
Botaurus
Bottine
Bra1N03
Brasov360
Brassw
Brentjens
BrucePennypacker
Bruno413
Bull3t
Burumbátor
Cabanero
CactiStaccingCrane
Cagliost
Caio
Caio2112
calsbert
Canberra User
capolatell
Carlos Nicolía
Carly805
Casisgaal
Cbliu
Cbuckley
Ccourouve
Cekli829
Cépey
Cereol89
CharlieEchoTango
Chemgirl131
Cheulou
Chi Mishitsuu
Chidgk1
Chimel31
Chiyako92
Chlod (OCTG)
Chlod (test)
Chrisportelli
Christoph Wagener
Chuanfuyin
Chuterix
Ciernik M
Cisco79
Citation bot
Citation bot 1
Citation bot 2
Citation bot 3
Citation bot 4
Civvì
CJDOS
clement57300
Cmulrooney
codairem
Conrad.Irwin
Coolsharkymd
Cordelia Chase
Coredesat
Coren
Corrina1234
Count druckula
CR85747
Crazy81
Cristabel0
Croonstad
Cross-j
Crustumerio
CTF83!
Ctruongngoc
cuissi
Cupidvogel
cursolis
CutOffTies
Cymbella
D&C Washer
D0nc0s
D100a
dadofsam
DAJF
Damonking
Danaphile
danielkueh
Daniil Maslyuk
Dank55
Dariam-Urahara
daubmir
Daveout
David spector
David_spector
davidships
Davisonio
Delphinus1997
Democraticmacguitarist
DemoiselleBrindacier
Demonguy1990
Denghiù
Denis73
Denisshtab
Dentaro
Der Ehm
Der wahre Jakob
Devadatta
Dferg
Dfergbot
Dfrankow
Diego Grez
Dieter Bald
Digitallife1995
Dima1
Dimdamdom
Dimon4ezzz
Dimsar01
Dionyziz
Dipod
Dirkb
Docmo
Dogman15
Donkey Hot-day
Donkey shot
Douglasboavista
Dqwyy
Dr. Van Nostrand
DragonZero
DrilBot
Drjt87
DRobert
Droigheann
DroopyDoggy
Drozdp
Drucker03
DueChayapol
Dunkson
E L Yekutiel
E85Bot
edelmauswaldgeist
Editor182
EdJogg
EGM6322S09TIAN
Egon Eagle
El3ctr0nika
Elgewen
Elkawe
Ellmist
Ellrbrown
Emdad Tafsir
Emilijaknezevic
Emils Hammer
Emojiwiki
Engerauer
EngineerFromVega
Enry Fridge
EnthusiastWorld37
EnzoSan777
EnzoSan97
Erdemaslancan
erdemaslancan
Eric444
Erik Baas
Erikev
Erlandinho
Esambuu
Escargot bleu
Eschenmoser
Esebi95
Ethanwatters
Eugene a
Eumolpo
Europeanguy01
Euskaldun
Explosivo
Fabullus
FachueberM39
Fahadhuzur
Fairfieldfencer
Fatidiot1234
Fattonyni
Fayenatic london
Fayzanzahid
fenwayguy
ferrybig
FIA2008
Fibe101
Fidech
Filmtechniker
Fils du Soleil
fjvelsen
Flipeicl
Flocky1
florescent
Fortunatissimo
Foxa0223
Francisco Leandro
Franciscoooooouu
Frank C. Müller
Frank Gosebruch
Frecklefoot
Freedom Wizard
French Tourist
Frila
Fritzbruno
Ftrebien
Fúlvio
Funkruf
Fuse809
FY3
Fyeaxel05
G(Bot)
G(x)
Gabrielchihonglee
gaegol
Gaidheal1
Gaioa
gbruin
Gedas86
GedSperber
gerald2008
gerardgiraud
Gershonj1
GG
Ghabara
Ghettopia
Ghostintears
Giftheck
Giftiger_wunsch
Gikü
Gillesmourey
Ginkgo2g
GiovanniS
Givern
Glegeros
Gluben
Gluons12
GMc
Gnivic
Goalsurfer
Gold Luigi
Goodone121
Göran Holbeck
Gpeterw
Gpvosbot
Grandia01
Graphikus
Gremista.32
Groupthink
Grrrrrrrrrrrrrr
Grumpyyoungman01
Gruszecki
Gui le Roi
Guiguioh
Gutter
Guusb
Guy Peters
guywest
Guy Without Name
gwendy
Gxynono
Haansn08
Hajiru
Hajiru
Hajj_3
Hamaryns
hamedrocker
Hapebalf
Harley Hartwell
HaSt
Hatashe
Hatto
Hatto0467
Hébus
Hddty
Hedwig Storch
Hellknowz
Helpme_reza
HenkdeRuiter
Henry McClean
HereToHelp
Hertz1888
hkmtrhah
Hob Gadling
Holladio
hoonchina
hooon42
HoraceAndTheSpider
Horcoff
Hounder4
Hueverto
Hymek
Icqgirl
Igel_B_TyMaHe
ihrtwiki
I Like Pie739
Immeasurable radiance
Imruz
imyoussef
Incola
indolering
Indy Smiff
Indy_Smiff
Innocent bystander
Innocent iwbot
INS Pirat
Insane93
Insanephantom
Ionmars10
ipeters61
IreneWyo
irishguy9221
Ischa1
Ismarker
It Is Me Here
ITA-ATU
ItsPugle
Ivan Levkovskiy
J 1982
J. Finkelstein
J. Smile (Love & V.A.V.I)
Ja_1207
ja_1207
Jacbacon
Jacquesverlaeken
JamsterYT
Jan Arvid Götesson
JanB46
Janke
jannikkappel
Januar255
jaredhimself
Jason7825
Jatilsharma
Javatusa
JavBol
JavierCantero
javiern
jay8g
jazzantz
jb1902
jbnewell
JCarlos PB
jcsedeno
JeanVitorSouza
JeffyP
JEHAN SHERKO
jemo2200
Jens Deriemaeker
jergen
Jeromemoreno
Jespa
jetse
JFHJr
jhh
JHo
Jhsounds
JHvW
Jidanni
Jimthing
jipje44
Jiraiya2005
Jirka Staffan Aubert
Jmel314159
Jmlanthan
jocelioandrade
Joe Sewell
Joey259
JOGIROX
Johamar
Joizashmo
Jonathanjfriend
Jordan Mitchell Barrett
Josep Baró
Joshnook
joshschr
josinj
Jotamide
Jotavio-9
Jouk22
jowiltshire
JozeSlb
Jpvinall
JQUIGNON
JRBC1
Jroberson108
Jrodriguezvillalobos
JTMnen
Judicious1
Juesch
Juggler2005
Juggler2005
Juhkovic
JukkaEmilVanaja
Julius-m
Jurak36
אריאל מואטי
Justin_Eiler
justinnhli
JV089Yayu
Jw21
JWD126
k2d
Kaihsu
Kalan
Kalendar
Karakarasuuuu
Karelj
Karl Gruber
Karl von Clausewitz
Karl_3
karlzt
Karthik Krishnan
Kasra092
Kat_ola7
Kathleen.wright5
Kattiel
Kazuki Ashiya
KeFe
Kenny McFly
Keruby
KevinJi9
Keyboard Editor
Kgagne
Khairul hazim
KielimiliisiBot
KieranMaher
Kigsz
Kiire
Killiondude
kimbr
Kimdorris
King Muli 12
Kingdon
Kire1975
Kiril Simeonovski
kiszto
Kizule
KizuleBot
Kleibs13
Kliek
KlonAdam
Klow
Knochen
KocmutD
Kodiologist
Koenraad
kondareddy
Konkordia
Kontrollstellekundl
Kostikoff
Koveras
Koxinga
KoxingaBot
Kreecher
kreecher
kronox
krughal
ksu6500
kunguz
Kürschner
Kwjbot
L1amw90
La carotte et le bâton
Labdajiwa
LabdajiwaBot
lachelt
Larshei
Leaf 1579043826
Legacy0100
Legion23
Lehva
Lemonaka
Leoboudv
Leonardo Da Vinci
LeoSpe
Lepsyleon
Lerichard
Levi78
Leviathan III
LGL87
LICA98
Lightsup55
Liggliluff
Lijnema
Lilolirocksursocks
Limperg
Linguist111
Liquidmetalrob
Lispir
Livingod
Lllovell
Lnemekhbayar
lolineko
lolsmiff
Loraelai
LordRapture
Lorry Gundersen
LotteV1991
Louiemantia
Lowena
Ltiler
LuCKY
LUGALzu
LukeSurl
Lunga de Bacurau
Lyn50
M Okamoto
M. Vince
M7bot
M9jojo0913
MA
Maareti
MABot
Mabrndt
Mac Dreamstate
Machnovetc
Madura mate
Maggyero
MagnusA
MagnusA.Bot
Mahanga
Mahatee
Majorly
Makassarpanassekali
Manajude
Manbooferie
ManlyMatt
Manuel M
Manuelt15
Manwë986
MarcoAurelio
MarioLOA
Mariuscreati
Marsupilami
Martina Nolte
Marxistfounder
Masur
Matej200
Materialscientist
MathCool10
Mathieu Le Piolot
Matias1799
Mauro Lanari
Mavz0r
maxclare
Maxi222777
Mbz1
MC10 (usurped)
MC10 Chess
Mcintireallen
mcy919
MD2015
MDGx
Mecena
Medgirl131
Mediafanatic17
Megathonic
Meho29
MeigyokuThmn
mekadva
Mess
Metalcore92
Mewaqua
Mfraissl
MicahBrwn
Michawiki
MichHerr
Micklalala
Mikael Häggström
Mike Selinker
Mikeybear
Mikez
Milicevic01
Minjaehyun
MIO
Mirochi
Miyabikikaku
MMH
Mmlov
Moemi83
Mohatatou
Monkey bb
Mori-umi
Motmel
Mouliric
moussiaszm
Mowerm
Mps2
Mr gronk
Mr tim111
Mr tim111
Mr.DD
MrBoo
mrevan
Mrkalvin
MrLinkinPark333
mrzhuai
MS10
msh210
MSY-07
mth8412
murinsky
Murtaza2000
Murtl
MVB
Myvh773
Mzajac
Nadiatalent
Nagura dokuro
Nalle&Lisa
Nanami Kamimura
NapoleonX
Narenhofer
NASCARfan0548
NASCARfan0548 (alt)
Nat70
Nauix26
Navarretedf
Nazeerfexilon
Ndystorms
nealpfox
nelsondavidd
Nemets777
Neodop
Nethency
Newwikiprofile001
Ngô Trung
Nhasive
Nick Fishman
Nick UA
Nick_michael
Nicnoc
Nicola Quirico
Nicolas ANCEAU
Nicoleon
Nightscream
NinetyCharacters
nirvana2013
Njain1091
NMChico24
Noah Kastin
Nodokara
Noon
Notem
Notrealname1234
now3d
nrainer
NRS0426
Nyuszika7H
Oathed
Ob_ivan
Obayd
Obayda
Obenhaus
Od1n
Odder
OdderBot
Odranoel93
Ojota
Olivaw-Daneel
Omerzu
Omid
On Wheezier Plot
One half 3544
OpenBot
Openstrings
Optimist on the run
Orderinchaos 2
ORIOLA
Otto von Bergen
Pablov95
Pacopac
Padd_y
Pankoken
Paperflyer
Paradisul
Paradoctor
Parcly Taxel
Pare Mo
Parjann
Partirritate
Pass276
Pasťo
Patchy1
Patilsaurabhr
Paul Pogonyshev
PBbot
Pedaretr
Pek the Penguin
Penssio
Pentzlin
Per Oktober
permacultura
Peter Bowman
Peter Christian Riemann
PeterJewell
PeterOliver
PeterSymonds
PeterSymposium
pfa.ruiz
Phatom87
philbert2.71828
PhiLiP zhwiki
PieRat
Piero
Pill
Pingumeister
Piotrpavel
Pizzahut2
Pjunkkar
Polocean
Pompomgalli
Pontificalibus
Ponydepression
Porplemontage
Powermax555
Poyass
Prenter2
ProjectHorizons
Ptbotgourou
Ptitguillaume
Purijj
Pyro_z
Pywikibot-test
Q102josh
Qaqqalik
Quackth
Quasi-grip
qubodup
Queen of Hearts
QuietHere
Qwirkle
R. Engelhardt
R.T.Argenton
Rabbitizer
Rafy
Rags18
Raid5
Rainwarrior
Raksidelic
Ralf Gartner
ramesh7283
Rando717
Ratisbon
Ratte
Rauenstein
Reading beans
Reallyeasytoremember
Reaper Eternal
ReCover
Red Sunset
Redaktoro
reddevil0728
RedHillian
RedWarn
Reiner Stoppok
Remkoow
Remmie93
Renamed user 8z9cl30vm1
RenéV
RenéV
RenéV
RenT
Revibot
Revibot I
Revibot II
Revibot III
Revolving_Bugbear
Rich0984
Ricky
Ricvelozo
Rishabhbhat
Ritulia
Rmrfstar
Rob Kam
robertmocanu.123
Robotus
Rockfang
RockfangBot
Rockman Dick
Rodrigo Tetsuo Argenton
Rodrigo.Argenton
Rodrigo.argenton
Rodrigo.T.Argenton
Rohieb
Rom4
Roman-miass
Romang
Romanophile
Rory O'Kane
Rosičák
Rougar
Roysoham.96
Rubin16
ruiroentgen
Runab
Runrun_923
RussBlau
Rusty Rubbish
S.m.46
Sabiusaugustus
Sabunero
Safinaskar
Saftgurka
Sagvhilversum
Sahand Ace
Sahasrahla
Samral
Samuel Wiki
Samvscat
Samwain
samwise
Sängerkrieg auf Wartburg
saraar
Sarı Saçlı
Sasha Krotov
SashaNein
sb008
Scarabocchio
Schnapper
SDrewth
SDrewthbot
Seboloidus
Seeteufel
Seiavoshy
Selena13
Semplicemars
Serge Lachinov
SergeyPosokhov
Serprex
Severinus
Shadd21
Shade
Shadow2
shakeelgilgity
Shantavira
Shattered Gnome
ShazidSharif
Shengfu10
Shiauyd
ShikiSuen
Shir-El too
Shogiru
Shrish Shankhdhar
Sidney
Sidney440
Sieger Junge
SietsL
Siga
SignBot
Signeraz
Silar
Silesianus
Silver Eyalced
SilvonenBot
Simba16
Singkong2005
Sinka
Sinse59
Sir Lothar
Siren-Com
Sjg
Sk4170
Skal
Skeptical Sapien
SkyLined
Skywindy
Slb nsk
Slicing
Smigles
Sminthopsis84
Smith609
Snehakrishna
Sniper (bot)
SocietyBox
Soczyczi
Sóhivatal
Sojourner in the earth
Sokac121
SoledadKabocha
Sorbas 48
Soundcontrol
SoWhy
Spannerjam
Spidermario
Spike-from-NH
SPNKs
Spongevob
Spray787
Spriosan
Spy-cicle
Sreejith Kumar
Ssilvers
Ssofan
St. Alex
Stauba
Steef389
SteMicha
Stephenamills
StephenFerg
Stevietheman
StMH
Stockrose
Strafidlo
Strainu
Stwalkerbot
Stwalkersock
Sueede
Sundayclose
Super Wang
SusikMkr
Svenopus
SvinayaGolova
SWM
Taher Almahdi
Takaishs
Joseph2302
Taric25
TaTo 713
TattooedLeprechaun
Tauʻolunga
tdf
teatrlab
TechyTommy
TedPavlic
Tedster007
Tengo las llaves
Teo.ostlund
Teroses
TextClick
Tfsy1272
The Dark Side
The Evil IP address
The Nature Box
TheDarkX
Thesaurisateur
The sum of all human knowledge
thevrchriss
Thewolfchild
Thrissel
Thunderforge
tickleonthetum
Tigers boy
Timl
Timl2k4
TimSmit
Timwi
TinucherianBot
TinucherianBot II
Tivedshambo
Tjahebro
tktsui
Tlsonic214
Tmv23
TolBot
TolTest
Tom-1674
Tomaterols
tomeasy
Tommyabrassart
tompok76
Toni Müller
Tonyjeff
Touriste
tow70
TPANE512
tradclimbr
Tregoweth
Triplecaña
Tryvix1509
Tsaryov357
Tsentral
TT mk2
Tukubazan
TURBANator1992
Tushar3011
Twilight Magic
Twilight-Brawl
Two lips
TWx4eABO5y
Typhlosion
Tyw7
ulca08
UltimateChance
Unnamed anon
Unuomoinblues
Urbeltz
Usien
Utkarsh Pandey
Utkarsh555
UvM
UY Scuti
V.narsikar
vadim.odynets
Vago
Vahagn Petrosyan
Vakulin
Valentim
Vanished user 127237
VascoAmaral
Vegetapple
Veleius
VengCodes
VerryFun
VibhijainBot
Vicarage
vicile
Vicond
Victor Schmidt mobil
Villy
Viltus
VineFynn
Visible Light
VitorMazuco
Vivan755
Vlad
vladik_p
Vladimir Sem
Vog
Voice of Clam
Voidxor
Vokirich
Vozho
w-j-s
W.andrea
w313g
waddinm
Walter Grassroot
war59312
Wasa Kawasaker
Wau
WCityMike
WCLL HK
WeeJeeVee
Wereon
WFinch
Wickey
WikiPate
WikiPediaAid
Wilcott
Will Pittenger
Willa-Mina
WizardOfOz
WolfgangRieger
WolfmanFP
Woodricr
Woogeroo
Wraithful
Wthjmkuiper
WTManila
WWBM
Wynne333
x1987x
Xavier66
Xehpuk
Xeno on an iPhone
Xenocidic
Xenowiki
Xilofonista
Xonique
XRayBot
XRayXII
Yamato-i
Yann Gag
YaouhPower
Yarfpr
Yeti-Hunter
Yhwos
YiFeiBot
Yoderj
Yoenit
YoshiDaSilva
yossigoldlust
Your_Highness
Yuafanda
YUKI TANAKA0722
Yuri Git
YuriSanCa
Yuuki (Wikimedian)
z4j3biz
Zachlp
Zafir94
ZakTek
zaqqthe
Zarvonov
ZeaForUs
Zhoxy
Zhuyifei1999
Zoomiebot
Zorglube
Zupez zeta
Айдар Шәйхи
Александр Васильев
Антон Черный
Асакура Йо
Вадим Соколов
Википравитель
Григорий Явир
Къарачайлы
Максим Крестинский
Руслан1977
Семён Владимирович
Сергей Соковнин
Симуран
Струјајое
Тр. Андрей
Эрик Картманез
أنون
איש שלום
אני_ואתה
מיקרוז
נטע
মো. মাহমুদুল আলম
தகவலுழவன்
స్వరలాసిక
관인생략
イマ
たけ2020
ムビチケ555
ゆっかりーん
ヨッサン
中村尚人
佛道儒墨
刻意
劉舜元
勇者プクリン
向井地由依
寿聖智
徐麟飞
方洪渐
景太郎
筑紫太郎
紫阅
結城さくら
红渡厨
胡祥又
臭氧層
身元不詳
阪神虎太
Trustable
Narenhofer
Graham87
Thosbsamsgom
BrendanIp
Matbla7
Simonjon
Turaids
Chenganassery
Luma.H
編集中
Marbhna
Ocelot
יוני2023
Sbaio
Tuvalkin
Stary90
Nikki
Fúlvio
Gluben
Opok2021
Edward Chernenko
RteeeeKed
SlyAceZeta
Unnamed anon
HouoA1
Carlos Nicolía
JoeyChen
Nodokara
Hatto
Keyboard Editor
Samuel Wiki
Ash787
יורם הורוביץ - שירים
OliwierJaszczyszyn
Oxking986
IrsY
LotteV1991
JOGIROX
ExplainsTrains
Roronoa Erica
Lorry Gundersen
Chlod (test)
Chlod (OCTG)
Zoomiebot
RedWarn
10nm
Khairul hazim
MSY-07
SuperN
[[Category:Board elections]]";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}