package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)^https?://vimeo\.com/[^/]+`)
var str = `https://vimeo.com/400532154/b0fedc9dc3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}