# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^| )(?:(?:https:\/\/)?(?:www\.)?github\.com\/(?<org>[^ \/\n]+)\/(?<repo>[^ \/\n]+)\/issues\/(?<number>[0-9]+)(?:\/)?)(?: |$)"
test_str = ("ASDFASDF\n"
"asdfasdfASdf\n"
"asdf\n"
"asdf\n\n"
"asdfasdf https://github.com/zeebe-io/backport-action/issues asdf github.com/zeebe-io/backport-action/issues/30 asdf\n"
"asdfasdf www.github.com/zeebe-io/\n"
"backport-action/issues/30 asdf\n\n"
"asdfasdf www.github.com/zeebe-io/backport-action/issues/30asdf\n"
"asdfasdfwww.github.com/zeebe-io/backport-action/issues/30 asdf\n"
"asdfasdfwww.github.com/zeebe-io/backport-action/issues/30asdf\n\n"
"asdfsdf https://www.github.com/zeebe-io/backport-action/issues/30 asdfasdfasdf\n"
"sadhkasjh https://github.com/zeebe-io/backport-action/issues/30/ asdjfkghasdf\n"
"sadfasdf asdf asdfsdf #123 asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf zeebe-io/zeebe#123 asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf #sdafsdf asdfasf#123 sadf #442\n\n"
"#123 asdasdasd\n"
"sadfasdf asdf asdfsdf #123 asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf #123asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf#123 asdfasf#123 sad\n"
"adasdasdasd #123\n\n"
"zeebe-io/zeebe#123 asdfas\n"
"sadfasdf asdf asdfsdf zeebe-io/\n"
"zeebe#123 asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf zeebe-io/zeebe#123 asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf zeebe-io/zeebe#123asdfasf#123 sad\n"
"sadfasdf asdf asdfsdf/zeebe-io/zeebe#123 asdfasf#123 sad\n"
"asdasfasf zeebe-io/zeebe#123\n\n"
"#123\n"
"closes#234asdfasdf\n"
"resolves #123123123123\n\n"
"#234\n\n"
"Bye bye")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.