re = /(\*(?!\/)|\/(?!\*)|[^\*\/]|[\n])+/
str = '/*b****
*comment
ac/*"*********/
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end