$re = '/(.+\/[^\.]\w+$)/m';
$str = 'https://blah.com/foo/bar
https://blah.com/foo/bar/
https://blah.com/foo/bar.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);