package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/diff\/\d{1,2}-\d{1,2}.?doc)`)
var str = `
<html>
<head>
<!--
-->
<title>Сайт школы 1311 :: Информация</title>
<meta name="Keywords" lang="ru" content="школа, 1311">
<meta name="Title" content="Сайт школы 1311">
<link rel=stylesheet href="../sch.css" type="text/css">
</head>
<body>
<table align="center" width="1024" border="0" cellspacing="0" cellpadding="0" bgcolor="#FFFFFF" background="../images/tblbg.png">
<tr>
<td align="center" valign="middle" rowspan="3" width="120">
<div align="center"><a href="/"><img src="/images/slogo.png" width="71" height="70" border="0" align="middle"></a></div>
</td>
<td align="LEFT" class="art-sm" colspan="2">
<table width="100%" border="0" cellspacing="0" cellpadding="0" bgcolor="#FFFFFF">
<tr>
<td width="33%" align="left" class="art-sm" bgcolor="#FFFFFF" height="22">
<a name="top"></a>
16 сентябрь 2020 16:52 </td>
<td width="33%" align="center" class="art-sm" bgcolor="#FFFFFF">
Уроки закончились </td>
<td align="right" class="art-sm" bgcolor="#FFFFFF">
27 <img src="../images/13.gif"> 5780 </td>
</tr>
</table>
</td>
</tr>
<tr>
<td align="center" valign="middle" colspan="2" height="26">
<div align="center">
<a href="/school/school.php" class="a-white">О школе</a> | <a href="/info/info.php" class="a-white-active">Информация</a> | <a href="/links/links.php" class="a-white">Ссылки</a> | <a href="http://museum.1311.ru" class="a-white" target="_blank">Музей</a> | <a href="/projects/projects.php" class="a-white">Проекты</a> | <a href="/school/contacts.php" class="a-white">Контакты</a> </div>
</td>
</tr>
<tr>
<td valign="middle" colspan="2" align="center" bgcolor="#FFFFFF" class="art-sm" height="22">
</td>
</tr>
</table><table align="center" width="1024" border="0" cellspacing="0" cellpadding="0" bgcolor="#FFFFFF">
<tr>
<td class="MenuTitle" valign="top"><table cellpadding="1" cellspacing="0" border="0" width="120">
<tr valign="middle" align="center">
<td colspan="2" align="center"> <a href="#bottom"><img src="../images/shevron_d.gif" width="20" border="0"></a></td>
</tr>
<tr>
<td colspan="2" class="meIt" align="right"><img src="../images/menu_up.gif" width="120"></td>
<tr>
<td class="meIt" align="right"><a href="info.php" class="meIt">ДОСКА ОБЪЯВЛЕНИЙ</a> </td>
</tr>
<tr>
<td align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="https://goo.gl/forms/LQ0OgEDvXe1IM1B63" class="meIt">ОБРАЩЕНИЕ В ШКОЛУ</a></td>
</tr>
<tr>
<td align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="olimpiada.php" class="meIt">ОЛИМПИАДЫ, КОНКУРСЫ, СОРЕВНОВАНИЯ</a> </td>
</tr>
<tr>
<td align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="/forum" class="meIt" target="_blank">ШКОЛЬНЫЙ
ФОРУМ</a> </td>
</tr>
<tr>
<td align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="info.php#rasp_dop" class="meIt">РАСПИСАНИЕ
ЗВОНКОВ</a></td>
</tr>
<tr>
<td align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="info.php#rasp_dop" class="meIt">РАСПИСАНИЕ
КРУЖКОВ И СЕКЦИЙ</a></td>
</tr>
<tr>
<td align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"> <a href="cab1.php" class="meIt">ЛИЧНЫЙ<br>
КАБИНЕТ РОДИТЕЛЕЙ</a></td>
</tr>
<tr>
<td class="meIt" align="right"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="info2.php#teachers" class="meIt">ИНФОРМАЦИЯ<br>
ДЛЯ<br>
УЧИТЕЛЕЙ</a></td>
</tr>
<tr align="right">
<td colspan="2"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr>
<td class="meIt" align="right"><a href="info2.php#vac" class="meIt">ВАКАНСИИ</a></td>
</tr>
<tr align="right">
<td colspan="2"><img src="../images/menu_sep.gif" width="90"></td>
</tr>
<tr align="right">
<td class="meIt">
<p><a href="../gallery3" class="meIt">ШКОЛЬНАЯ<br>
WEB ГАЛЕРЕЯ</a></p>
</td>
</tr>
<tr>
<td class="meIt" align="right"><img src="../images/menu_down.gif" width="120" height="7"></td>
</tr>
<tr>
<td align="center"><a href="#top"><img src="../images/shevron_u.gif" width="20" height="20" border="0"></a></td>
</tr>
</table></td>
<td bgcolor="#FFFFFF"><table width="100%" border="0" cellspacing="2" cellpadding="3">
<tr>
<td class="art-h3" bgcolor="#EEEEFF"><p>Доска объявлений</p></td>
</tr>
<tr>
<td><hr></td>
</tr>
<tr>
<td><a href="https://drive.google.com/file/d/1m-MerCb1i2oWcRPhYeJ-7jHH0qVhWk9t/view?usp=sharing" target="_blank">Расписание занятий в 7 – 9 классах по подготовке к Всероссийской и Московской олимпиаде школьников (занятия ведут преподаватели Ассоциации победителей олимпиад)</a><br>
<br>
<a href="https://drive.google.com/file/d/1RjWafLick_xgRbjx5fKrJV28PG7ba54n/view?usp=sharing" target="_blank">Расписание занятий в 10 – 11 классах по подготовке к Всероссийской и Московской олимпиаде школьников (занятия ведут преподаватели Ассоциации победителей олимпиад)</a><br>
<hr></td></tr>
<tr>
<td><hr></td>
</tr>
<tr>
<td class="art-std" bgcolor="#FFFFFF"><p align="center"><span class="art-h3"><br>
<p class="art-h3" align="center">Годовой календарный учебный график<br>
школы на 2020-2021 учебный год </span></p>
<table width="100%" border="0" align="center" class="art-std">
<tr>
<td align="center" class="art-h4">
<a href="/info/2020-2021/2020 - 2021 учебный год с изменениями и пояснениями.pdf" target=_blank>
<img src="/info/2020-2021/Schedule-2020-2021_1.jpg" align="center" width="600"></a></td>
</tr>
<tr>
<td align="center" class="art-h4">
<a href="/info/2020-2021/2020 - 2021 учебный год с изменениями и пояснениями.pdf" target=_blank><u>
<img src="/info/2020-2021/Schedule-2020-2021_2.jpg" align="center" width="600"></a></td>
</tr>
<tr>
<td align="center" class="art-h4">
Файл с годовым календарным учебным графиком доступен
<a href="/info/2020-2021/2020 - 2021 учебный год с изменениями и пояснениями.pdf" target=_blank><u><b>по ссылке</b></u></a>.</td>
</tr>
<tr>
<td><hr></td>
</tr>
<tr>
<td class="art-std"><img src="images/tt.jpeg" width="150" class="img-left">
<p class="art-h3" align="center"><a name="rasp"></a>Изменения в расписании уроков на</p>
<ul>
<li><a href="/diff/16-09.doc">16 сентября</a></li><li><a href="/diff/17-09.doc">17 сентября</a></li><li><a href="/diff/17-09_nach.doc">17 сентября (начальная школа)</a></li><li><a href="/diff/16-09_nach.doc">16 сентября (начальная школа)</a></li> </ul>
<p class="art-h3" align="center"><span class="art-red"><i>Примечание. Постоянное расписание уроков опубликовано в электронном журнале.<br>
Здесь выкладываются только изменения в расписании.</i></span></p></tr>
<tr>
<td><hr></td>
</tr>
<tr>
<tr>
<td class="art-std"> <img src="images/bell.gif" width="125" height="115" class="img-left">
<p class="art-h3" align="center">Расписание звонков</p>
<table>
<tr><td> <font> 1 урок</font></td><td><font> 08:30 - 09:10 </font></td><td></td></td></td></tr>
<tr><td><font> 1 перемена </font></td><td> <font> 09:10 - 09:25 </font></td><td></td><td><font> Завтрак: 1абв, 2абв, 3а</font></td></tr>
<tr><td> <font> 2 урок</font></td><td><font> 09:25 - 10:05 </font></td><td></td></td></td></tr>
<tr><td><font> 2 перемена </font></td><td> <font> 10:05 - 10:20 </font></td><td></td><td><font> Завтрак: 3бв, 4абв, 5аб, 6абв</font></td></tr>
<tr><td> <font> 3 урок</font></td><td><font> 10:20 - 11:00 </font></td><td></td></td></td></tr>
<tr><td><font> 3 перемена </font></td><td> <font> 11:00 - 11:15 </font></td><td></td><td><font> Завтрак: 7абв, 8аб, 9аб, 10аб, 11аб</font></td></tr>
<tr><td> <font> 4 урок</font></td><td><font> 11:15 - 11:55 </font></td><td></td></td></td></tr>
<tr><td><font> 4 перемена </font></td><td> <font> 11:55 - 12:15 </font></td><td></td><td><font> Обед: 1абв, 2абв, 3а</font></td></tr>
<tr><td> <font> 5 урок</font></td><td><font> 12:15 - 12:55 </font></td><td></td></td></td></tr>
<tr><td><font> 5 перемена </font></td><td> <font> 12:55 - 13:10 </font></td><td></td><td><font> Обед: 3бв, 4абв, 5аб, 6абв</font></td></tr>
<tr><td> <font> 6 урок</font></td><td><font> 13:10 - 13:50 </font></td><td></td></td></td></tr>
<tr><td><font> 6 перемена </font></td><td> <font> 13:50 - 14:10 </font></td><td></td><td><font> Обед: 7абв, 8аб, 9аб, 10аб, 11аб</font></td></tr>
<tr><td> <font> 7 урок</font></td><td><font> 14:10 - 14:50 </font></td><td></td></td></td></tr>
<tr><td><font> 7 перемена </font></td><td> <font> 14:50 - 15:00 </font></td><td></td><td><font> </font></td></tr>
</table></td>
</tr>
<tr>
<td><hr></td>
</tr>
<tr>
<td class="article-h">
<p align="center"><img src="images/ttc.jpg" width="112" height="115" class="img-left"><a name="rasp_dop"></a><span class="art-h3">Расписание
кружков и секций на 2019-20 уч. год<br>
</span><a href="https://drive.google.com/open?id=1jbp1dYhYNkt78J91XFvRYF9ZAlCeESqh" target="_blank">Средняя и старшая школа</a><br>
<a href="https://drive.google.com/open?id=1i7h-noeu3So4Q1IdbgK4RElEB1u6GdD_" target="_blank">Начальная школа</a><br><br>
<a href="https://drive.google.com/open?id=1gDF5xx76DiHc4uBn38lUNejd9T2BfvTt" target="_blank">Положение о Группе Развития И Социализации</a><br>
<a href="https://drive.google.com/open?id=16PXyyHuRfiNWgk4vm_eRbCxTA-olb8GZ" target="_blank">Рабочая программа Группы Развития и Социализации</a><br>
<a href="https://drive.google.com/open?id=11bFE_q19Qu6VsewodoZC-2LrPwawDhLs" target="_blank">Стоимость кружков и секций</a><br></p>
</td>
</tr>
<tr>
<td> </td>
</tr>
</table>
<hr>
<div align="center">
<a name="bottom"></a><a href="#top"><img src="/images/shevron_um.gif" border="0"></a>
<a href="/school/school.php" class="title"> О школе </a>|<a href="/info/info.php" class="title-active"> Информация </a>|<a href="/links/links.php" class="title"> Ссылки </a>|<a href="http://museum.1311.ru" class="title"> Музей </a>|<a href="/projects/projects.php" class="title"> Проекты </a>|<a href="/school/contacts.php" class="title"> Контакты </a> <a href="#top"><img src="/images/shevron_um.gif" border="0"></a></div>
<hr></td>
</tr>
</table>
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}