$re = '/([Mm]on|[Tt](?:hurs|ues)|[Ww]ednes|[Ff]ri|[Ss](?:un|atur))(?: |,|day(?: |,|(?:\'|)s))|[Ee]veryday|[Ww]eekday|[Ww]eekend/';
$str = 'Wake me up Wednesdays, thursday\'s, and Friday at 7:15, and make this a nagging alarm. Repeat it every 10 minutes until 8:30.
Wake me up on the Weekends at 7:17 AM.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);