$re = '/^\-?[0-9]+(e[0-9]+)?(\.[0-9]+)?$/m';
$str = '1e2
1000
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);