package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]+[.][0-9]{2})\s*$`)
var str = `12.43
123.32 2345.54
124.43`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}