re = /^(\+91\d{10}|0\d{10}|[1-9]\d{9})$/m
str = '+911234567891
01234567891
1234567891
0123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end