#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(todo|fixme)(?>\s*:?\s*)(?!http|\w+-\d+).*"
Local $sString = "TODO: AS-123 no match" & @CRLF & _
"todo: as-123 no match" & @CRLF & _
"fixme: https://jira.company.com/browse/AS-14965 no match" & @CRLF & _
"fixme: https://jira.company.com" & @CRLF & _
"fixme as-123 no match" & @CRLF & _
"todo:as-123 no match" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"todo match" & @CRLF & _
"todo match" & @CRLF & _
"todo:match" & @CRLF & _
"todo :match" & @CRLF & _
"todo123" & @CRLF & _
"todo : match" & @CRLF & _
"todo: match" & @CRLF & _
"fixme: match" & @CRLF & _
"todo: match https://jira.company.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")