const regex = new RegExp('(?!\\p{IsHan}\\n)[^\\p{IsHan}\\n?。,?!]+', 'gm')
const str = `He is 45 today
你今天45岁了
这个句子没有数字
Ok I see`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}