$re = '/\b(?:www\.|https?:)(?!\S*\b(?:bscscan|google|binance|t\.me)\b)\S+/m';
$str = 'https://bscscan.com testing123
website: https://www.yahoo.com
another one www.bing.com is great
www.binance.org
http://bob.bscscan.com
https://twitter.google.com
https://google.twitter.com
https://t.me/rawr omg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);