package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<m>[^\?]+)\?(?:.*)?`)
var str = `/test/uri?
/test/uri2?x=123&y=456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}