package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(?i)(oms).*`)
var str = `oms Oms OMS OmS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}