package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w+(?:-\w+)*\.sql`)
var str = `AAAAAAAA.BBBBBBBBBBB.sql
AAAAAAAA.BBBBB-CCCCCCC.sql`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}