re = /^[a-z0-9_]{1}[a-z0-9\-_–-]*(\.[a-z0-9\-_–-]+)*@[a-z0-9–-]{1}[a-z0-9\-_–-]*(\.[a-z0-9\-_–-]+)*\.[a-z]{2,4}$/
str = 'Vendortimeout@gmail.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end