using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0|[-+]?[1-9][0-9]*)$";
string input = @"float varieties:
4848.48
+01.20
0.45
01.45
20.20
20.2000000
-1.23
-0.23
0.0
0.00000
.3
-.4
+.4
+.30
+1.1
+00001.1
int varieties:
1234
43210
12012
+1
0
-0
+0
01234
000001234
+00
-00
+00123
-00123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}