#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\))(.+?)(\d\/\d{4}.*)"
Local $sString = "Cloud Innovators Solution (9 months)Social Media Marketing Specialist1/2020 - 10/2020" & @CRLF & _
"StoriCamPK (less than a month)Marketing Communications Manager7/2022" & @CRLF & _
"Coleman Estate Agents (13 years, 11 months)Director8/2009" & @CRLF & _
"Coleman Estate Agents NewYork (13 years, 11 months)Director8/2009" & @CRLF & _
"TCS (less than a month)Head of Search Engine Optimization ➤ Brand & Strategy || Go-to-market Strategy || Content Marketer8/2010" & @CRLF & _
"Collins Securities Pty Ltd (less than a month) Credit ManagerInvalid date" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")