import re
regex = re.compile(r"\b([A-Z]+)0(?=\d{3}\b)", flags=re.MULTILINE)
test_str = ("SK0498 should return SK498 (total digits = 4 = omit the single leading zero)\n\n"
"AA007 should still return AA007 (because the leading zeros are double, and total digits is only 3)\n\n"
"UA2138 returns UA2138 (no leading zeros involved)\n\n"
"BA023 should return BA023 (keep the zero because total number of digits is only 3), however BA0234 should return BA234 (total digits is 4 with a single leading zero that should be omitted).\n"
"AA0007")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)