re = /(?:(?<!\d))(?:(?:31(?:0[13578]|1[02])|(?:30|29)(?:0[13-9]|1[0-2])|(?:0[1-9]|1[0-9]|2[0-9])(?:0[1-9]|1[0-2]))[0-9]{2}-?[0-9]|290200-?[4-9]|2902(?:(?!00)[02468][048]|[13579][26])-?[0-3])[0-9]{3}(?:(?!\d))/m
str = '290261-5252'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end