package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((|[0-1])[1-9]:[0-5][0-9](| )(am|pm))$`)
var str = `11:38 am`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}